Apple anuncia novas exigências para apps e updates a partir de 27 de março

Imagem de destaque

Com o iOS 12 já instalado em mais de 80% dos dispositivos em uso no mundo todo, a Apple anunciou hoje novas regras para novos apps e updates que entrarão em vigor daqui a uma semana exata, em 27 de março.

A partir dessa data, todos os novos aplicativos e atualizações de apps para iPhones e iPads, incluindo binários universais, terão que ser construídos com o SDK do iOS 12.1 e obrigatoriamente suportarem as telas do iPhone XS Max ou do iPad Pro de 12,9 polegadas (terceira geração). Ou seja, em teoria nenhum app poderá mais rodar com bordas pretas.

A Apple também disse que exigirá screenshots para esses dispositivos em novos envios, a partir de 27/3, e que todos os novos apps/updates para o Apple Watch deverão ser construídos com o SDK do watchOS 5.1 e suportarem o Apple Watch Series 4.

Na minha visão, todas essas regras são bastante válidas. A Apple dá tempo mais do que suficiente para desenvolvedores se adaptarem (essa exigência de agora foi originalmente anunciada em setembro do ano passado), o problema é que parece que nem sempre a empresa de fato aplica essas regras sobre apps. Existem alguns (oi, OLX) que até hoje não rodam bem no iPhone X, para vocês terem uma ideia.

Vamos ver se agora vai.

Posts recomendados
Comentários

O Modo Escuro foi ativado ou desativado.
Atualize esta página para ver os comentários.


Carregar mais posts recentes