Beta do watchOS 4.3.1 traz novo alerta de incompatibilidade para apps antigos

De forma análoga ao que foi implementado no iOS 10.3 e no macOS High Sierra, que em breve não suportarão mais apps de 32 bits, um aviso similar pintou na primeira versão beta do watchOS 4.3.1.

Conforme mostram as imagens acima, alguns apps antigos estão mostrando um alerta de incompatibilidade ao serem abertos no watchOS 4.3.1, indicando que os desenvolvedores precisarão atualizá-los para que continuem funcionando em futuras versões do sistema. Provavelmente, vêm aí grandes mudanças no watchOS 5 — que, muito provavelmente, será apresentado em junho na Worldwide Developers Conference (WWDC) 2018.

Por ora, é claro, trata-se apenas de um alerta. Ao tocar em “OK”, o usuário é levado para dentro do app normalmente.

Lembrando que, há meros dez dias, entrou em vigor uma nova regra da Apple a qual impede que desenvolvedores atualizem apps criados originalmente para o watchOS 1. A partir de agora só são aceitos apps nativos, construídos com o seu SDK completo.

via 9to5Mac

Taggeado:

Posts relacionados

Comentários